Re: [PATCH] pwm: img: Turn final 'else if' into 'else' in img_pwm_config

From: Nick Desaulniers
Date: Fri Mar 08 2019 - 16:23:56 EST


On Fri, Mar 8, 2019 at 1:18 PM Uwe Kleine-KÃnig
<u.kleine-koenig@xxxxxxxxxxxxxx> wrote:
>
> On Fri, Mar 08, 2019 at 10:38:11AM -0800, Nick Desaulniers wrote:
> > On Fri, Mar 8, 2019 at 12:53 AM Uwe Kleine-KÃnig
> > <u.kleine-koenig@xxxxxxxxxxxxxx> wrote:
> > >
> > > On Thu, Mar 07, 2019 at 03:36:28PM -0700, Nathan Chancellor wrote:
> > > > When building with -Wsometimes-uninitialized, Clang warns:
> > > >
> > > > drivers/pwm/pwm-img.c:126:13: error: variable 'timebase' is used
> > > > uninitialized whenever 'if' condition is false
> > > > [-Werror,-Wsometimes-uninitialized]
> > > >
> > > > The final else if functions as an else; make that explicit so that Clang
> > > > understands that timebase cannot be used uninitialized.
> > > >
> > > > Link: https://github.com/ClangBuiltLinux/linux/issues/400
> > > > Signed-off-by: Nathan Chancellor <natechancellor@xxxxxxxxx>
> > > > ---
> > > > drivers/pwm/pwm-img.c | 2 +-
> > > > 1 file changed, 1 insertion(+), 1 deletion(-)
> > > >
> > > > diff --git a/drivers/pwm/pwm-img.c b/drivers/pwm/pwm-img.c
> > > > index 815f5333bb8f..1cc5fbe1e1d3 100644
> > > > --- a/drivers/pwm/pwm-img.c
> > > > +++ b/drivers/pwm/pwm-img.c
> > > > @@ -123,7 +123,7 @@ static int img_pwm_config(struct pwm_chip *chip, struct pwm_device *pwm,
> > > > } else if (mul <= max_timebase * 512) {
> > > > div = PWM_CTRL_CFG_SUB_DIV0_DIV1;
> > > > timebase = DIV_ROUND_UP(mul, 512);
> > > > - } else if (mul > max_timebase * 512) {
> > > > + } else {
> > > > dev_err(chip->dev,
> > > > "failed to configure timebase steps/divider value\n");
> > > > return -EINVAL;
> > >
> > > This can even be simplified further.
> > >
> > > From the probe function we have:
> > >
> > > pwm_chip->max_period_ns = NSEC_PER_SEC * 512 * max_timebase / input_clk_hz
> >
> > I had trouble verifying `input_clk_hz` in the above. The divisor is
> > `clk_get_rate(pwm->pwm_clk)`, but is it guaranteed to always be
> > `input_clk_hz`? If so, where?
>
> In the probe function it's called "clk_rate". We have:
>
> clk_rate = clk_get_rate(pwm->pwm_clk);
> ...
> val = (u64)NSEC_PER_SEC * 512 * pwm->data->max_timebase;
> do_div(val, clk_rate);
> pwm->max_period_ns = val;
>
> and in img_pwm_config we have:
>
> input_clk_hz = clk_get_rate(pwm_chip->pwm_clk);
>
> I used the name used in img_pwm_config with the intention that my
> reasoning is easier to understand, but obviously I failed.
>
> This by the way highlights another patch opportunity: Unify the names
> that the same thing gets the same name in the different functions. This
> doesn't only affect "clk_rate" vs "input_clk_hz", but also "pwm_chip"
> vs. "pwm".

Sure, those seem like nice little cleanups that will help with
maintainability. Would you mind sending a patch for those, and I'll
review? Otherwise Nathan's patch exists and is ready to go.
--
Thanks,
~Nick Desaulniers