Re: [RFC PATCH v3 0/5] tracing: common error_log for ftrace
From: Masami Hiramatsu
Date: Tue Mar 12 2019 - 02:26:14 EST
Hi Tom,
On Tue, 5 Mar 2019 23:06:46 +0900
Masami Hiramatsu <mhiramat@xxxxxxxxxx> wrote:
> On Mon, 4 Mar 2019 17:36:43 -0600
> > Changes from v2:
> >
> > - Added [n] numbering as suggested by Masami
>
Hmm, this seems a bit different what I suggested.
I'm trying to port probe event's error report on
your error log, and I found that the number is
just shifted as below.
When I filled the log with errors.
=============
/sys/kernel/debug/tracing # cat error_log
[1] trace_kprobe: error: Invalid unsigned integer string
Command: r10aa00:foo/bar vfs
^
...
[7] trace_kprobe: error: Group name must follow C naming convention
Command: p:a-b/bar vfs_read
^
[8] trace_kprobe: error: Event name is too long
Command: p:a/barrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrr vfs_read
=============
And do one more error,
=============
/sys/kernel/debug/tracing # cat error_log
[1] trace_kprobe: error: Maxactive is too big
Command: r0xaa00:foo/bar vfs
....
[7] trace_kprobe: error: Event name is too long
Command: p:a/barrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrr vfs_read
^
[8] trace_kprobe: error: Event name must follow C naming convention
Command: p:a/bar.c vfs_read
^
=============
The number of logs are changed :( This can confuse users.
I think it is better to keep the number as a unique number for
each entry as below.
=============
/sys/kernel/debug/tracing # cat error_log
[2] trace_kprobe: error: Maxactive is too big
Command: r0xaa00:foo/bar vfs
....
[8] trace_kprobe: error: Event name is too long
Command: p:a/barrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrr vfs_read
^
[9] trace_kprobe: error: Event name must follow C naming convention
Command: p:a/bar.c vfs_read
^
=============
Thank you,
--
Masami Hiramatsu <mhiramat@xxxxxxxxxx>