Re: [PATCH v3 2/2] drivers/base/memory.c: Rename the misleading parameter

From: Michal Hocko
Date: Fri Mar 29 2019 - 05:13:29 EST


On Fri 29-03-19 16:29:15, Baoquan He wrote:
> The input parameter 'phys_index' of memory_block_action() is actually
> the section number, but not the phys_index of memory_block. Fix it.

I have tried to explain that the naming is mostly a relict from the past
than really a misleading name http://lkml.kernel.org/r/20190326093315.GL28406@xxxxxxxxxxxxxx
Maybe it would be good to reflect that in the changelog

> Signed-off-by: Baoquan He <bhe@xxxxxxxxxx>

btw. I've acked the previous version as well.

> ---
> v2->v3:
> Rename the parameter to 'start_section_nr' from 'sec'.
>
> drivers/base/memory.c | 7 ++++---
> 1 file changed, 4 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/base/memory.c b/drivers/base/memory.c
> index cb8347500ce2..9ea972b2ae79 100644
> --- a/drivers/base/memory.c
> +++ b/drivers/base/memory.c
> @@ -231,13 +231,14 @@ static bool pages_correctly_probed(unsigned long start_pfn)
> * OK to have direct references to sparsemem variables in here.
> */
> static int
> -memory_block_action(unsigned long phys_index, unsigned long action, int online_type)
> +memory_block_action(unsigned long start_section_nr, unsigned long action,
> + int online_type)
> {
> unsigned long start_pfn;
> unsigned long nr_pages = PAGES_PER_SECTION * sections_per_block;
> int ret;
>
> - start_pfn = section_nr_to_pfn(phys_index);
> + start_pfn = section_nr_to_pfn(start_section_nr);
>
> switch (action) {
> case MEM_ONLINE:
> @@ -251,7 +252,7 @@ memory_block_action(unsigned long phys_index, unsigned long action, int online_t
> break;
> default:
> WARN(1, KERN_WARNING "%s(%ld, %ld) unknown action: "
> - "%ld\n", __func__, phys_index, action, action);
> + "%ld\n", __func__, start_section_nr, action, action);
> ret = -EINVAL;
> }
>
> --
> 2.17.2
>

--
Michal Hocko
SUSE Labs