Re: [PATCH v3 0/5] PCI: Patch series to support Thunderbolt without any BIOS support

From: Bjorn Helgaas
Date: Mon Apr 15 2019 - 18:20:07 EST


On Mon, Apr 15, 2019 at 05:08:41PM +0000, Nicholas Johnson wrote:
> I have split the last patch into the two patches as suggested. One to
> add the new parameter and another to rename them nicely.
>
> There is no longer depreciation of the old kernel parameters - they are
> simply dropped, as suggested.

I did not actually suggest dropping the old parameters. I said I
wasn't sure the user confusion of deprecating the old names in favor
of new names was worth the trouble. I suspect we should just *add*
one new parameter and leave the old ones unchanged.

> I would find it cleaner to just do a single patch without the
> depreciation, as both patches change the same things, doubling up on the
> number of patch lines. I can still do this if requested.
>
> Bjorn has fixed a trivial problem with the second patch in the series
> not applying cleanly due to changes since I first sent it. He said not
> to bother fixing it.

What I actually meant was "you correctly posted v2 based on my master
branch at the time, and since my master branch has moved from v5.0-rc1
to v5.1-rc1 since your v2 post, I'll do trivial fixes for that."

But since you're posting v3 *today*, and my master branch has been at
v5.1-rc1 since March 18, you should rebase your patches on top of that
branch first.

> Nicholas Johnson (5):
> PCI: Consider alignment of hot-added bridges when distributing
> available resources
> PCI: Cleanup comments in setup-bus.c to meet kernel coding style
> guidelines

We also talked about moving trivial cleanups to be at the end. The
important things should be first in the series, with cleanups at the
end. That way backporting is easier, since people may want to
backport only the real fixes, ignoring things like typo fixes.

> PCI: Fix serious bug when sizing bridges with additional size
> PCI: modify kernel parameters to differentiate between MMIO and
> MMIO_PREF sizes
> PCI: Rename pci=hpiosize,hpmemsize,hpmemprefsize to be more readable
>
> .../admin-guide/kernel-parameters.txt | 7 +-
> drivers/pci/pci.c | 18 +-
> drivers/pci/setup-bus.c | 512 +++++++++---------
> include/linux/pci.h | 3 +-
> 4 files changed, 287 insertions(+), 253 deletions(-)
>
> --
> 2.20.1
>