[PATCH v2 1/2] blkdev.h: Introduce bytes_to_sectors helper function

From: Marcos Paulo de Souza
Date: Wed May 01 2019 - 21:58:06 EST


This function takes an argument to specify the size of a block device,
in bytes, and return the number of sectors of 512 bytes.

Reviewed-by: Chaitanya Kulkarni <chaitanya.kulkarni@xxxxxxx>
Signed-off-by: Marcos Paulo de Souza <marcos.souza.org@xxxxxxxxx>
---
Changes from v1:
Rename size_to_sectors to bytes_to_sectors. (Martin K. Petersen)

Changes from RFC:
Reworked the documentation of size_to_sectors by removing a sentence that was
explaining the size -> sectors math, which wasn't necessary given the
description prior to the example. (suggested by Chaitanya)

include/linux/blkdev.h | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

diff --git a/include/linux/blkdev.h b/include/linux/blkdev.h
index 317ab30d2904..7ade2e24dbae 100644
--- a/include/linux/blkdev.h
+++ b/include/linux/blkdev.h
@@ -871,6 +871,23 @@ static inline struct request_queue *bdev_get_queue(struct block_device *bdev)
#define SECTOR_SIZE (1 << SECTOR_SHIFT)
#endif

+/**
+ * bytes_to_sectors - Convert size in bytes to number of sectors of 512 bytes
+ * @bytes: number of bytes to be converted to sectors
+ *
+ * Description:
+ * Kernel I/O operations are always made in "sectors". In order to set the
+ * correct number of sectors for a given number of bytes, we need to group the
+ * number of bytes in "sectors of 512 bytes" by shifting the size value by 9,
+ * which is the same than dividing the size by 512.
+ *
+ * Returns the number of sectors by the given number of bytes.
+ */
+static inline sector_t bytes_to_sectors(long long bytes)
+{
+ return bytes >> SECTOR_SHIFT;
+}
+
/*
* blk_rq_pos() : the current sector
* blk_rq_bytes() : bytes left in the entire request
--
2.16.4