Re: [PATCH 17/18] perf/x86/intel/rapl: Support multi-die/package

From: Ingo Molnar
Date: Mon May 06 2019 - 07:49:04 EST

* Len Brown <lenb@xxxxxxxxxx> wrote:

> static inline struct rapl_pmu *cpu_to_rapl_pmu(unsigned int cpu)
> {
> - unsigned int pkgid = topology_logical_package_id(cpu);
> + unsigned int pkgid = topology_logical_die_id(cpu);

Yeah, I think Peter pointed this out before: why is the local variable
still named 'pkg' when we now have a die ID?

The other patches have such problems too: when new facilities are
introduced and used then function names and variable names need to be
harmonized. Makes for rather confusing code otherwise, which invites bugs
down the road.

There's many such instances left in this series, please review the whole
patchset for such problems.