Re: [PATCH 4/7] sched: Add sched_load_rq tracepoint

From: Steven Rostedt
Date: Mon May 06 2019 - 09:53:23 EST

On Mon, 6 May 2019 11:08:59 +0200
Peter Zijlstra <peterz@xxxxxxxxxxxxx> wrote:

> These functions really should be called trace_*()
> Also; I _really_ hate how fat they are. Why can't we do simple straight
> forward things like:
> trace_pelt_cfq(cfq);
> trace_pelt_rq(rq);
> trace_pelt_se(se);
> And then have the thing attached to the event do the fat bits like
> extract the path and whatnot.

I'd like to avoid functions called "trace_*" that are not trace events.
It's getting confusing when I see a "trace_*()" function and then go
look for the corresponding TRACE_EVENT() just to find out that one does
not exist.

sched_trace_*() maybe?

-- Steve