Re: [PATCH net-next 10/11] net: stmmac: Introduce selftests support

From: Andrew Lunn
Date: Wed May 08 2019 - 22:24:44 EST


> +static int stmmac_test_eee(struct stmmac_priv *priv)
> +{
> + struct stmmac_extra_stats *initial, *final;
> + int timeout = 100;
> + int ret;
> +
> + ret = stmmac_test_loopback(priv);
> + if (ret)
> + goto out_free_final;
> +
> + /* We have no traffic in the line so, sooner or later it will go LPI */
> + while (--timeout) {
> + memcpy(final, &priv->xstats, sizeof(*final));
> +
> + if (final->irq_tx_path_in_lpi_mode_n >
> + initial->irq_tx_path_in_lpi_mode_n)
> + break;
> + msleep(100);
> + }
> +
> + if (!timeout) {
> + ret = -ETIMEDOUT;
> + goto out_free_final;
> + }

Retries would be a better name than timeout.

Also, 100 * 100 ms seems like a long time.

> +static int stmmac_filter_check(struct stmmac_priv *priv)
> +{
> + if (!(priv->dev->flags & IFF_PROMISC))
> + return 0;
> +
> + netdev_warn(priv->dev, "Test can't be run in promiscuous mode!\n");
> + return 1;

Maybe return EOPNOTSUPP here,

> +}
> +
> +static int stmmac_test_hfilt(struct stmmac_priv *priv)
> +{
> + unsigned char gd_addr[ETH_ALEN] = {0x01, 0x0c, 0xcd, 0x04, 0x00, 0x00};
> + unsigned char bd_addr[ETH_ALEN] = {0x06, 0x07, 0x08, 0x09, 0x0a, 0x0b};

What does gd and bd mean?

> + struct stmmac_packet_attrs attr = { };
> + int ret;
> +
> + if (stmmac_filter_check(priv))
> + return -EOPNOTSUPP;

and just return the error code from the call.

> +
> + ret = dev_mc_add(priv->dev, gd_addr);
> + if (ret)
> + return ret;
> +
> + attr.dst = gd_addr;
> +
> + /* Shall receive packet */
> + ret = __stmmac_test_loopback(priv, &attr);
> + if (ret)
> + goto cleanup;
> +
> + attr.dst = bd_addr;
> +
> + /* Shall NOT receive packet */
> + ret = __stmmac_test_loopback(priv, &attr);
> + ret = !ret;

What is this test testing? gd is a multicast, where as bd is not. I
expect the hardware treats multicast different to unicast. So it would
make more sense to test two different multicast addresses, one which
has been added via dev_mc_addr, and one that has not?

> +
> +cleanup:
> + dev_mc_del(priv->dev, gd_addr);
> + return ret;
> +}
> +
> +static int stmmac_test_pfilt(struct stmmac_priv *priv)
> +{
> + unsigned char gd_addr[ETH_ALEN] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06};
> + unsigned char bd_addr[ETH_ALEN] = {0x06, 0x07, 0x08, 0x09, 0x0a, 0x0b};
> + struct stmmac_packet_attrs attr = { };
> + int ret;
> +
> + if (stmmac_filter_check(priv))
> + return -EOPNOTSUPP;
> +
> + ret = dev_uc_add(priv->dev, gd_addr);
> + if (ret)
> + return ret;
> +
> + attr.dst = gd_addr;
> +
> + /* Shall receive packet */
> + ret = __stmmac_test_loopback(priv, &attr);
> + if (ret)
> + goto cleanup;

gb is a multicast address. Does dev_uc_add() return an error? If it
does not we should not expect it to actually work, since a multicast
address should not match a unicast address?

You also seem to be missing a test for adding a unicast address via
dev_uc_add() and receiving packets for that address, but not receiving
multicast packets.

> +static const struct stmmac_test {
> + char name[ETH_GSTRING_LEN];
> + int lb;
> + int (*fn)(struct stmmac_priv *priv);
> +} stmmac_selftests[] = {
> + {
> + .name = "MAC Loopback ",
> + .lb = STMMAC_LOOPBACK_MAC,
> + .fn = stmmac_test_loopback,

stmmac_test_mac_loopback might be a better name.

> + }, {
> + .name = "PHY Loopback ",
> + .lb = STMMAC_LOOPBACK_PHY,
> + .fn = stmmac_test_phy_loopback,
> + }, {

Andrew