Re: [RFC PATCH 00/11] bpf, trace, dtrace: DTrace BPF program type implementation and sample use

From: Kris Van Hees
Date: Thu May 23 2019 - 01:20:32 EST


On Wed, May 22, 2019 at 01:16:25PM -0700, Alexei Starovoitov wrote:
> On Wed, May 22, 2019 at 12:12:53AM -0400, Kris Van Hees wrote:
> >
> > Could you elaborate on why you believe my patches are not adding generic
> > features? I can certainly agree that the DTrace-specific portions are less
> > generic (although they are certainly available for anyone to use), but I
> > don't quite understand why the new features are deemed non-generic and why
> > you believe no one else can use this?
>
> And once again your statement above contradicts your own patches.
> The patch 2 adds new prog type BPF_PROG_TYPE_DTRACE and the rest of the patches
> are tying everything to it.
> This approach contradicts bpf philosophy of being generic execution engine
> and not favoriting one program type vs another.

I am not sure I understand where you see a contradiction. What I posted is
a generic feature, and sample code that demonstrates how it can be used based
on the use-case that I am currently working on. So yes, the sample code is
very specific but it does not restrict the use of the cross-prog-type tail-call
feature. That feature is designed to be generic.

Probes come in different types (kprobe, tracepoint, perf event, ...) and they
each have their own very specific data associated with them. I agree 100%
with you on that. And sometimes tracing makes use of those specifics. But
even from looking at the implementation of the various probe related prog
types (and e.g. the list of helpers they each support) it shows that there is
a lot of commonality as well. That common functionality is common to all the
probe program types, and that is where I suggest introducing a program type
that captures the common concept of a probe, so perhaps a better name would
be BPF_PROG_TYPE_PROBE.

The principle remains the same though... I am proposing adding support for
program types that provide common functionality so that programs for various
program types can make use of the more generic programs stored in prog arrays.

> I have nothing against dtrace language and dtrace scripts.
> Go ahead and compile them into bpf.
> All patches to improve bpf infrastructure are very welcomed.
>
> In particular you brought up a good point that there is a use case
> for sharing a piece of bpf program between kprobe and tracepoint events.
> The better way to do that is via bpf2bpf call.
> Example:
> void bpf_subprog(arbitrary args)
> {
> }
>
> SEC("kprobe/__set_task_comm")
> int bpf_prog_kprobe(struct pt_regs *ctx)
> {
> bpf_subprog(...);
> }
>
> SEC("tracepoint/sched/sched_switch")
> int bpf_prog_tracepoint(struct sched_switch_args *ctx)
> {
> bpf_subprog(...);
> }
>
> Such configuration is not supported by the verifier yet.
> We've been discussing it for some time, but no work has started,
> since there was no concrete use case.
> If you can work on adding support for it everyone will benefit.
>
> Could you please consider doing that as a step forward?

This definitely looks to be an interesting addition and I am happy to look into
that further. I have a few questions that I hope you can shed light on...

1. What context would bpf_subprog execute with? If it can be called from
multiple different prog types, would it see whichever context the caller
is executing with? Or would you envision bpf_subprog to not be allowed to
access the execution context because it cannot know which one is in use?

2. Given that BPF programs are loaded with a specification of the prog type,
how would one load a code construct as the one you outline above? How can
you load a BPF function and have it be used as subprog from programs that
are loaded separately? I.e. in the sample above, if bpf_subprog is loaded
as part of loading bpf_prog_kprobe (prog type KPROBE), how can it be
referenced from bpf_prog_tracepoint (prog type TRACEPOINT) which would be
loaded separately?

Cheers,
Kris