Re: [RFC][PATCH] kernel.h: Add generic roundup_64() macro

From: Steven Rostedt
Date: Thu May 23 2019 - 13:39:47 EST


On Thu, 23 May 2019 09:51:29 -0700
Linus Torvalds <torvalds@xxxxxxxxxxxxxxxxxxxx> wrote:

> On Thu, May 23, 2019 at 8:27 AM Steven Rostedt <rostedt@xxxxxxxxxxx> wrote:
> >
> > I haven't yet tested this, but what about something like the following:
>
> So that at least handles the constant case that the normal "roundup()"
> case also handles.
>
> At the same time, in the case you are talking about, I really do
> suspect that we have a (non-constant) power of two, and that you
> should have just used "round_up()" which works fine regardless of
> size, and is always efficient.

I think you are correct in this.

act_size = roundup_64(attr->length, MLX5_SW_ICM_BLOCK_SIZE(dm_db->dev));

Where we have:

#define MLX5_SW_ICM_BLOCK_SIZE(dev) (1 << MLX5_LOG_SW_ICM_BLOCK_SIZE(dev))

Which pretty much guarantees that it is a power of two. Thus, the real
fix here is simply to s/roundup/round_up/ as you suggest.

>
> On a slight tangent.. Maybe we should have something like this:
>
> #define size_fn(x, prefix, ...) ({ \
> typeof(x) __ret; \
> switch (sizeof(x)) { \
> case 1: __ret = prefix##8(__VA_ARGS__); break; \
> case 2: __ret = prefix##16(__VA_ARGS__); break; \
> case 4: __ret = prefix##32(__VA_ARGS__); break; \
> case 8: __ret = prefix##64(__VA_ARGS__); break; \
> default: __ret = prefix##bad(__VA_ARGS__); \
> } __ret; })
>
> #define type_fn(x, prefix, ...) ({ \
> typeof(x) __ret; \
> if ((typeof(x))-1 > 1) \
> __ret = size_fn(x, prefix##_u, __VA_ARGS__); \
> else \
> __ret = size_fn(x, prefix##_s, __VA_ARGS__); \
> __ret; })
>
> which would allow typed integer functions like this. So you could do
> something like
>
> #define round_up(x, y) size_fn(x, round_up_size, x, y)
>
> and then you define functions for round_up_size8/16/32/64 (and you

You mean define functions for round_up_size_{u|s}8/16/32/64

> have toi declare - but not define - round_up_sizebad()).
>
> Of course, you probably want the usual "at least use 'int'" semantics,
> in which case the "type" should be "(x)+0":
>
> #define round_up(x, y) size_fn((x)+0, round_up_size, x, y)
>
> and the 8-bit and 16-bit cases will never be used.

I'm curious to what the advantage of that is?

>
> We have a lot of cases where we end up using "type overloading" by
> size. The most explicit case is perhaps "get_user()" and "put_user()",
> but this whole round_up thing is another example.
>
> Maybe we never really care about "char" and "short", and always want
> just the "int-vs-long-vs-longlong"? That would make the cases simpler
> (32 and 64). And maybe we never care about sign. But we could try to
> have some unified helper model like the above..

It may be simpler and perhaps more robust if we keep the char and short
cases.

I'm fine with adding something like this for round_up(), but do we want
to have a generic roundup_64() as well? I'm also thinking that we
perhaps should test for power of two on roundup():

#define roundup(x, y) ( \
{ \
typeof(y) __y = y; \
typeof(x) __x; \
\
if (__y & (__y - 1)) \
__x = round_up(x, __y); \
else \
__x = (((x) + (__y - 1)) / __y) * __y; \
__x; \
})


-- Steve