Re: [PATCH -next v2] drm/amdgpu: return 'ret' in amdgpu_pmu_init

From: Joe Perches
Date: Sat Jun 22 2019 - 14:13:40 EST


On Sat, 2019-06-22 at 21:05 +0800, Mao Wenan wrote:
> There is one warning:
> drivers/gpu/drm/amd/amdgpu/amdgpu_pmu.c: In function âamdgpu_pmu_initâ:
> drivers/gpu/drm/amd/amdgpu/amdgpu_pmu.c:249:6: warning: variable âretâ set but not used [-Wunused-but-set-variable]
> int ret = 0;
[]
> v1->v2: change the subject for this patch; change the indenting when it calls init_pmu_by_type; use the value 'ret' in
> amdgpu_pmu_init().
[]
> diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_pmu.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_pmu.c
[]
> @@ -252,8 +252,8 @@ int amdgpu_pmu_init(struct amdgpu_device *adev)
> case CHIP_VEGA20:
> /* init df */
> ret = init_pmu_by_type(adev, df_v3_6_attr_groups,
> - "DF", "amdgpu_df", PERF_TYPE_AMDGPU_DF,
> - DF_V3_6_MAX_COUNTERS);
> + "DF", "amdgpu_df", PERF_TYPE_AMDGPU_DF,
> + DF_V3_6_MAX_COUNTERS);

trivia:

The indentation change seems superfluous and
appears to make the code harder to read.

You could also cc Jonathan Kim who wrote all of this.