Re: [PATCH 4/9] drm: meson: vpp: use proper macros instead of magic constants

From: Kevin Hilman
Date: Mon Jun 24 2019 - 19:15:34 EST


Julien Masson <jmasson@xxxxxxxxxxxx> writes:

> This patch add new macros which are used to set the following
> registers:
> - VPP_OSD_SCALE_COEF_IDX
> - VPP_DOLBY_CTRL
> - VPP_OFIFO_SIZE
> - VPP_HOLD_LINES
> - VPP_SC_MISC
> - VPP_VADJ_CTRL
>
> Signed-off-by: Julien Masson <jmasson@xxxxxxxxxxxx>

[...]

> @@ -97,20 +97,22 @@ void meson_vpp_init(struct meson_drm *priv)
> else if (meson_vpu_is_compatible(priv, "amlogic,meson-gxm-vpu")) {
> writel_bits_relaxed(0xff << 16, 0xff << 16,
> priv->io_base + _REG(VIU_MISC_CTRL1));
> - writel_relaxed(0x20000, priv->io_base + _REG(VPP_DOLBY_CTRL));
> - writel_relaxed(0x1020080,
> + writel_relaxed(VPP_PPS_DUMMY_DATA_MODE,
> + priv->io_base + _REG(VPP_DOLBY_CTRL));
> + writel_relaxed(0x108080,

nit: still a magic constant here, and it's not obvious why it's
different from the current one.

Kevin