Re: [PATCH v1 5/6] mm: Add logic for separating "aerated" pages from "raw" pages

From: Dave Hansen
Date: Tue Jun 25 2019 - 16:24:46 EST


On 6/19/19 3:33 PM, Alexander Duyck wrote:
> Add a set of pointers we shall call "boundary" which represents the upper
> boundary between the "raw" and "aerated" pages. The general idea is that in
> order for a page to cross from one side of the boundary to the other it
> will need to go through the aeration treatment.

Aha! The mysterious "boundary"!

But, how can you introduce code that deals with boundaries before
introducing the boundary itself? Or was that comment misplaced?

FWIW, I'm not a fan of these commit messages. They are really hard to
map to the data structures.

One goal in this set is to avoid creating new data structures.
We accomplish that by reusing the free lists to hold aerated and
non-aerated pages. But, in order to use the existing free list,
we need a boundary to separate aerated from raw.

Further:

Pages are temporarily removed from the free lists while aerating
them.

This needs a justification why you chose this path, and also what the
larger implications are.

> By doing this we should be able to make certain that we keep the aerated
> pages as one contiguous block on the end of each free list. This will allow
> us to efficiently walk the free lists whenever we need to go in and start
> processing hints to the hypervisor that the pages are no longer in use.

You don't really walk them though, right? It *keeps* you from having to
ever walk the lists.

I also don't see what the boundary has to do with aerated pages being on
the tail of the list. If you want them on the tail, you just always
list_add_tail() them.

> And added advantage to this approach is that we should be reducing the
> overall memory footprint of the guest as it will be more likely to recycle
> warm pages versus the aerated pages that are likely to be cache cold.

I'm confused. Isn't an aerated page non-present on the guest? That's
worse than cache cold. It costs a VMEXIT to bring back in.

> Since we will only be aerating one zone at a time we keep the boundary
> limited to being defined for just the zone we are currently placing aerated
> pages into. Doing this we can keep the number of additional poitners needed
> quite small.

pointers ^

> +struct list_head *__aerator_get_tail(unsigned int order, int migratetype);
> static inline struct list_head *aerator_get_tail(struct zone *zone,
> unsigned int order,
> int migratetype)
> {
> +#ifdef CONFIG_AERATION
> + if (order >= AERATOR_MIN_ORDER &&
> + test_bit(ZONE_AERATION_ACTIVE, &zone->flags))
> + return __aerator_get_tail(order, migratetype);
> +#endif
> return &zone->free_area[order].free_list[migratetype];
> }

Logically, I have no idea what this is doing. "Go get pages out of the
aerated list?" "raw list"? Needs comments.

> +static inline void aerator_del_from_boundary(struct page *page,
> + struct zone *zone)
> +{
> + if (PageAerated(page) && test_bit(ZONE_AERATION_ACTIVE, &zone->flags))
> + __aerator_del_from_boundary(page, zone);
> +}
> +
> static inline void set_page_aerated(struct page *page,
> struct zone *zone,
> unsigned int order,
> @@ -28,6 +59,9 @@ static inline void set_page_aerated(struct page *page,
> /* record migratetype and flag page as aerated */
> set_pcppage_migratetype(page, migratetype);
> __SetPageAerated(page);
> +
> + /* update boundary of new migratetype and record it */
> + aerator_add_to_boundary(page, zone);
> #endif
> }
>
> @@ -39,11 +73,19 @@ static inline void clear_page_aerated(struct page *page,
> if (likely(!PageAerated(page)))
> return;
>
> + /* push boundary back if we removed the upper boundary */
> + aerator_del_from_boundary(page, zone);
> +
> __ClearPageAerated(page);
> area->nr_free_aerated--;
> #endif
> }
>
> +static inline unsigned long aerator_raw_pages(struct free_area *area)
> +{
> + return area->nr_free - area->nr_free_aerated;
> +}
> +
> /**
> * aerator_notify_free - Free page notification that will start page processing
> * @zone: Pointer to current zone of last page processed
> @@ -57,5 +99,20 @@ static inline void clear_page_aerated(struct page *page,
> */
> static inline void aerator_notify_free(struct zone *zone, int order)
> {
> +#ifdef CONFIG_AERATION
> + if (!static_key_false(&aerator_notify_enabled))
> + return;
> + if (order < AERATOR_MIN_ORDER)
> + return;
> + if (test_bit(ZONE_AERATION_REQUESTED, &zone->flags))
> + return;
> + if (aerator_raw_pages(&zone->free_area[order]) < AERATOR_HWM)
> + return;
> +
> + __aerator_notify(zone);
> +#endif
> }

Again, this is really hard to review. I see some possible overhead in a
fast path here, but only if aerator_notify_free() is called in a fast
path. Is it? I have to go digging in the previous patches to figure
that out.

> +static struct aerator_dev_info *a_dev_info;
> +struct static_key aerator_notify_enabled;
> +
> +struct list_head *boundary[MAX_ORDER - AERATOR_MIN_ORDER][MIGRATE_TYPES];
> +
> +static void aerator_reset_boundary(struct zone *zone, unsigned int order,
> + unsigned int migratetype)
> +{
> + boundary[order - AERATOR_MIN_ORDER][migratetype] =
> + &zone->free_area[order].free_list[migratetype];
> +}
> +
> +#define for_each_aerate_migratetype_order(_order, _type) \
> + for (_order = MAX_ORDER; _order-- != AERATOR_MIN_ORDER;) \
> + for (_type = MIGRATE_TYPES; _type--;)
> +
> +static void aerator_populate_boundaries(struct zone *zone)
> +{
> + unsigned int order, mt;
> +
> + if (test_bit(ZONE_AERATION_ACTIVE, &zone->flags))
> + return;
> +
> + for_each_aerate_migratetype_order(order, mt)
> + aerator_reset_boundary(zone, order, mt);
> +
> + set_bit(ZONE_AERATION_ACTIVE, &zone->flags);
> +}

This function appears misnamed as it's doing more than boundary
manipulation.

> +struct list_head *__aerator_get_tail(unsigned int order, int migratetype)
> +{
> + return boundary[order - AERATOR_MIN_ORDER][migratetype];
> +}
> +
> +void __aerator_del_from_boundary(struct page *page, struct zone *zone)
> +{
> + unsigned int order = page_private(page) - AERATOR_MIN_ORDER;
> + int mt = get_pcppage_migratetype(page);
> + struct list_head **tail = &boundary[order][mt];
> +
> + if (*tail == &page->lru)
> + *tail = page->lru.next;
> +}

Ewww. Please just track the page that's the boundary, not the list head
inside the page that's the boundary.

This also at least needs one comment along the lines of: Move the
boundary if the page representing the boundary is being removed.


> +void aerator_add_to_boundary(struct page *page, struct zone *zone)
> +{
> + unsigned int order = page_private(page) - AERATOR_MIN_ORDER;
> + int mt = get_pcppage_migratetype(page);
> + struct list_head **tail = &boundary[order][mt];
> +
> + *tail = &page->lru;
> +}
> +
> +void aerator_shutdown(void)
> +{
> + static_key_slow_dec(&aerator_notify_enabled);
> +
> + while (atomic_read(&a_dev_info->refcnt))
> + msleep(20);

We generally frown on open-coded check/sleep loops. What is this for?

> + WARN_ON(!list_empty(&a_dev_info->batch));
> +
> + a_dev_info = NULL;
> +}
> +EXPORT_SYMBOL_GPL(aerator_shutdown);
> +
> +static void aerator_schedule_initial_aeration(void)
> +{
> + struct zone *zone;
> +
> + for_each_populated_zone(zone) {
> + spin_lock(&zone->lock);
> + __aerator_notify(zone);
> + spin_unlock(&zone->lock);
> + }
> +}

Why do we need an initial aeration?

> +int aerator_startup(struct aerator_dev_info *sdev)
> +{
> + if (a_dev_info)
> + return -EBUSY;
> +
> + INIT_LIST_HEAD(&sdev->batch);
> + atomic_set(&sdev->refcnt, 0);
> +
> + a_dev_info = sdev;
> + aerator_schedule_initial_aeration();
> +
> + static_key_slow_inc(&aerator_notify_enabled);
> +
> + return 0;
> +}
> +EXPORT_SYMBOL_GPL(aerator_startup);
> +
> +static void aerator_fill(struct zone *zone)
> +{
> + struct list_head *batch = &a_dev_info->batch;
> + int budget = a_dev_info->capacity;

Where does capacity come from?

> + unsigned int order, mt;
> +
> + for_each_aerate_migratetype_order(order, mt) {
> + struct page *page;
> +
> + /*
> + * Pull pages from free list until we have drained
> + * it or we have filled the batch reactor.
> + */

What's a reactor?

> + while ((page = get_aeration_page(zone, order, mt))) {
> + list_add_tail(&page->lru, batch);
> +
> + if (!--budget)
> + return;
> + }
> + }
> +
> + /*
> + * If there are no longer enough free pages to fully populate
> + * the aerator, then we can just shut it down for this zone.
> + */
> + clear_bit(ZONE_AERATION_REQUESTED, &zone->flags);
> + atomic_dec(&a_dev_info->refcnt);
> +}

Huh, so this is the number of threads doing aeration? Didn't we just
make a big deal about there only being one zone being aerated at a time?
Or, did I misunderstand what refcnt is from its lack of clear
documentation?

> +static void aerator_drain(struct zone *zone)
> +{
> + struct list_head *list = &a_dev_info->batch;
> + struct page *page;
> +
> + /*
> + * Drain the now aerated pages back into their respective
> + * free lists/areas.
> + */
> + while ((page = list_first_entry_or_null(list, struct page, lru))) {
> + list_del(&page->lru);
> + put_aeration_page(zone, page);
> + }
> +}
> +
> +static void aerator_scrub_zone(struct zone *zone)
> +{
> + /* See if there are any pages to pull */
> + if (!test_bit(ZONE_AERATION_REQUESTED, &zone->flags))
> + return;

How would someone ask for the zone to be scrubbed when aeration has not
been requested?

> + spin_lock(&zone->lock);
> +
> + do {
> + aerator_fill(zone);

Should this say:

/* Pull pages out of the allocator into a local list */

?

> + if (list_empty(&a_dev_info->batch))
> + break;

/* no pages were acquired, give up */

> + spin_unlock(&zone->lock);
> +
> + /*
> + * Start aerating the pages in the batch, and then
> + * once that is completed we can drain the reactor
> + * and refill the reactor, restarting the cycle.
> + */
> + a_dev_info->react(a_dev_info);

After reading (most of) this set, I'm going to reiterate my suggestion:
please find new nomenclature. I can't parse that comment and I don't
know whether that's because it's a bad comment or whether you really
mean "cycle" the english word or "cycle" referring to some new
definition relating to this patch set.

I've asked quite nicely a few times now.

> + spin_lock(&zone->lock);
> +
> + /*
> + * Guarantee boundaries are populated before we
> + * start placing aerated pages in the zone.
> + */
> + aerator_populate_boundaries(zone);

aerator_populate_boundaries() has apparent concurrency checks via
ZONE_AERATION_ACTIVE. Why are those needed when this is called under a
spinlock?