Re: [PATCH 1/2] staging: rts5208: Rewrite redundant if statement to improve code style

From: Joe Perches
Date: Wed Jun 26 2019 - 13:41:55 EST


On Wed, 2019-06-26 at 16:28 +0200, Tobias Nießen wrote:
> This commit uses the fact that
>
> if (a) {
> if (b) {
> ...
> }
> }
>
> can instead be written as
>
> if (a && b) {
> ...
> }
>
> without any change in behavior, allowing to decrease the indentation
> of the contained code block and thus reducing the average line length.

unrelated and trivially:

> diff --git a/drivers/staging/rts5208/sd.c b/drivers/staging/rts5208/sd.c
[]
> @@ -4507,20 +4507,19 @@ int sd_execute_write_data(struct scsi_cmnd *srb, struct rtsx_chip *chip)
[]
> + if (sd_lock_state &&
> + (sd_card->sd_lock_status & SD_LOCK_1BIT_MODE)) {
> + sd_card->sd_lock_status |= (
> + SD_UNLOCK_POW_ON | SD_SDR_RST);

This could go on a single line like the &= ~() equivalent below.
It hardly matters if it's > 80 chars.

> + if (CHK_SD(sd_card)) {
> + retval = reset_sd(chip);
> + if (retval != STATUS_SUCCESS) {
> + sd_card->sd_lock_status &= ~(SD_UNLOCK_POW_ON | SD_SDR_RST);
> + goto sd_execute_write_cmd_failed;
> }
> -
> - sd_card->sd_lock_status &= ~(SD_UNLOCK_POW_ON | SD_SDR_RST);
> }
> +
> + sd_card->sd_lock_status &= ~(SD_UNLOCK_POW_ON | SD_SDR_RST);
> }
> }
> }