Re: linux-next: manual merge of the char-misc tree with the driver-core tree

From: Nathan Chancellor
Date: Mon Jul 01 2019 - 14:39:48 EST


On Mon, Jul 01, 2019 at 07:09:40PM +1000, Stephen Rothwell wrote:
> Hi all,
>
> Today's linux-next merge of the char-misc tree got a conflict in:
>
> drivers/hwtracing/coresight/of_coresight.c
>
> between commit:
>
> 418e3ea157ef ("bus_find_device: Unify the match callback with class_find_device")
>
> from the driver-core tree and commits:
>
> 22aa495a6477 ("coresight: Rename of_coresight to coresight-platform")
> 20961aea982e ("coresight: platform: Use fwnode handle for device search")
>
> from the char-misc tree.
>
> I fixed it up (I removed the file and added the following merge fix patch)
> and can carry the fix as necessary. This is now fixed as far as linux-next
> is concerned, but any non trivial conflicts should be mentioned to your
> upstream maintainer when your tree is submitted for merging. You may
> also want to consider cooperating with the maintainer of the conflicting
> tree to minimise any particularly complex conflicts.
>
> From: Stephen Rothwell <sfr@xxxxxxxxxxxxxxxx>
> Date: Mon, 1 Jul 2019 19:07:20 +1000
> Subject: [PATCH] coresight: fix for "bus_find_device: Unify the match callback
> with class_find_device"
>
> Signed-off-by: Stephen Rothwell <sfr@xxxxxxxxxxxxxxxx>
> ---
> drivers/hwtracing/coresight/coresight-platform.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/hwtracing/coresight/coresight-platform.c b/drivers/hwtracing/coresight/coresight-platform.c
> index 3c5ceda8db24..fc67f6ae0b3e 100644
> --- a/drivers/hwtracing/coresight/coresight-platform.c
> +++ b/drivers/hwtracing/coresight/coresight-platform.c
> @@ -37,7 +37,7 @@ static int coresight_alloc_conns(struct device *dev,
> return 0;
> }
>
> -int coresight_device_fwnode_match(struct device *dev, void *fwnode)
> +int coresight_device_fwnode_match(struct device *dev, const void *fwnode)
> {
> return dev_fwnode(dev) == fwnode;
> }
> --
> 2.20.1
>
> --
> Cheers,
> Stephen Rothwell

Hi Stephen,

The attached patch is needed in addition to this to avoid a build error
about incompatible pointer types (in the commit message).

Cheers,
Nathan