Re: [PATCH v5 2/2] dt-bindings: mtd: Document Macronix raw NAND controller bindings

From: Sergei Shtylyov
Date: Thu Jul 04 2019 - 04:29:20 EST


Hello!

On 03.07.2019 10:15, Mason Yang wrote:

Document the bindings used by the Macronix raw NAND controller.

Signed-off-by: Mason Yang <masonccyang@xxxxxxxxxxx>
---
Documentation/devicetree/bindings/mtd/mxic-nand.txt | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)
create mode 100644 Documentation/devicetree/bindings/mtd/mxic-nand.txt

diff --git a/Documentation/devicetree/bindings/mtd/mxic-nand.txt b/Documentation/devicetree/bindings/mtd/mxic-nand.txt
new file mode 100644
index 0000000..ddd7660
--- /dev/null
+++ b/Documentation/devicetree/bindings/mtd/mxic-nand.txt
@@ -0,0 +1,20 @@
+Macronix Raw NAND Controller Device Tree Bindings
+-------------------------------------------------
+
+Required properties:
+- compatible: should be "macronix,nand-controller"
+- reg: should contain 1 entrie for the registers
+- interrupts: interrupt line connected to this raw NAND controller
+- clock-names: should contain "ps_clk", "send_clk" and "send_dly_clk"
+- clocks: should contain 3 phandles for the "ps_clk", "send_clk" and
+ "send_dly_clk" clocks
+
+Example:
+
+ nand: mxic-nfc@43c30000 {

The node names should be generic, and the DT spec 0.2 (section 2.2.2) even has documented "nand-controller", please rename.

+ compatible = "macronix,nand-controller";
+ reg = <0x43c30000 0x10000>;
+ reg-names = "regs";
+ clocks = <&clkwizard 0>, <&clkwizard 1>, <&clkc 15>;
+ clock-names = "send_clk", "send_dly_clk", "ps_clk";
+ };


MBR, Sergei