Re: [PATCH 2/5] sched/fair: rename sum_nr_running to sum_h_nr_running

From: Srikar Dronamraju
Date: Thu Jul 25 2019 - 22:17:58 EST


* Vincent Guittot <vincent.guittot@xxxxxxxxxx> [2019-07-19 09:58:22]:

> sum_nr_running will track rq->nr_running task and sum_h_nr_running
> will track cfs->h_nr_running so we can use both to detect when other
> scheduling class are running and preempt CFS.
>
> There is no functional changes.
>
> Signed-off-by: Vincent Guittot <vincent.guittot@xxxxxxxxxx>
> ---
>
> ld_moved = 0;
> - if (busiest->nr_running > 1) {
> + if (busiest->cfs.h_nr_running > 1) {

We should be looking for nr_running here.
There could be only one cfs task but that may not be the current running
task, so it could be a good one to be picked for load balancing.

No?

> /*
> * Attempt to move tasks. If find_busiest_group has found
> * an imbalance but busiest->nr_running <= 1, the group is
> --
> 2.7.4
>

--
Thanks and Regards
Srikar Dronamraju