[PATCH tip/core/rcu 0/8] RCU list-traversal lockdep updates for v5.4
From: Paul E. McKenney
Date: Thu Aug 01 2019 - 18:43:15 EST
Hello!
This series provides enhancements to RCU pointer and list macros, all
courtesy of Joel Fernandes:
1. Rename rcu_dereference_raw_notrace() to _check().
2. Remove redundant debug_locks check in rcu_read_lock_sched_held().
3. Add support for consolidated-RCU reader checking.
4. Remove custom check for RCU readers.
5. Add lockdep condition to fix for_each_entry().
6. Convert to use built-in RCU list checking.
7. Pass lockdep condition to pcm_mmcfg_list iterator.
8. Use built-in RCU list checking for acpi_ioremaps list.
Thanx, Paul
------------------------------------------------------------------------
Documentation/RCU/Design/Requirements/Requirements.html | 2
arch/powerpc/include/asm/kvm_book3s_64.h | 2
arch/x86/pci/mmconfig-shared.c | 5 -
drivers/acpi/osl.c | 6 -
drivers/base/base.h | 1
drivers/base/core.c | 10 ++
drivers/base/power/runtime.c | 15 ++-
include/linux/rcu_sync.h | 4
include/linux/rculist.h | 38 +++++++--
include/linux/rcupdate.h | 9 +-
kernel/rcu/Kconfig.debug | 11 ++
kernel/rcu/update.c | 67 ++++++++++------
kernel/trace/ftrace_internal.h | 8 -
kernel/trace/trace.c | 4
net/ipv4/fib_frontend.c | 3
15 files changed, 132 insertions(+), 53 deletions(-)