[PATCH 08/73] perf tools: Rename perf_evlist__purge() to evlist__purge()

From: Jiri Olsa
Date: Fri Sep 13 2019 - 09:28:57 EST


Rename (perf_evlist__purge) to evlist__purge(), so we don't have a
name clash when we add (perf_evlist__purge) in libperf.

Link: http://lkml.kernel.org/n/tip-snvcdpyj28haygnvkuocxeh7@xxxxxxxxxxxxxx
Signed-off-by: Jiri Olsa <jolsa@xxxxxxxxxx>
---
tools/perf/util/evlist.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/tools/perf/util/evlist.c b/tools/perf/util/evlist.c
index d71fafd472ea..ac738b90a71f 100644
--- a/tools/perf/util/evlist.c
+++ b/tools/perf/util/evlist.c
@@ -124,7 +124,7 @@ static void perf_evlist__update_id_pos(struct evlist *evlist)
perf_evlist__set_id_pos(evlist);
}

-static void perf_evlist__purge(struct evlist *evlist)
+static void evlist__purge(struct evlist *evlist)
{
struct evsel *pos, *n;

@@ -155,7 +155,7 @@ void evlist__delete(struct evlist *evlist)
perf_thread_map__put(evlist->core.threads);
evlist->core.cpus = NULL;
evlist->core.threads = NULL;
- perf_evlist__purge(evlist);
+ evlist__purge(evlist);
evlist__exit(evlist);
free(evlist);
}
--
2.21.0