Re: [PATCH v5 10/14] software node: rename is_array to is_inline

From: Andy Shevchenko
Date: Wed Oct 16 2019 - 03:59:46 EST


On Tue, Oct 15, 2019 at 11:22:06AM -0700, Dmitry Torokhov wrote:
> On Mon, Oct 14, 2019 at 10:37:20AM +0300, Andy Shevchenko wrote:
> > On Fri, Oct 11, 2019 at 04:07:17PM -0700, Dmitry Torokhov wrote:
> > > We do not need a special flag to know if we are dealing with an array,
> > > as we can get that data from ratio between element length and the data
> > > size, however we do need a flag to know whether the data is stored
> > > directly inside property_entry or separately.
> >
> > > - if (prop->is_array)
> > > + if (!prop->is_inline)
> >
> > > - if (p->is_array) {
> > > + if (!p->is_inline) {
> >
> > > - if (src->is_array) {
> > > + if (!src->is_inline) {
> >
> > May we have positive conditionals instead?
>
> I was trying to limit the context churn. I can definitely change
> property_get_pointer(), but the other 2 I think are better in the
> current form.
>
> >
> > > + * @is_inline: True when the property value is stored directly in
> >
> > I think word 'directly' is superfluous here.
> > Or, perhaps, 'stored directly' -> 'embedded'
>
> I'm OK with "embedded".
>
> >
> > > + * &struct property_entry instance.
> >
> > > + * @pointer: Pointer to the property when it is stored separately from
> > > + * the &struct property_entry instance.
> >
> > 'separately from' -> 'outside' ?
>
> Umm, I think I prefer "separately" actually.
>
> >
> > > + * @value: Value of the property when it is stored inline.
> >
> > 'stored inline' -> 'embedded in the &struct...' ?
>
> I was trying to have a link "stored inline" -> "is_inline".
>
> Do we want to change the flag to be "is_embedded"?

In dictionaries I have

embedded <-> unilateral
inline <-> ???

Perhaps native speaker can jump in and help here.

My point is to be consistent in the terms we are using.

--
With Best Regards,
Andy Shevchenko