Re: [RESEND PATCH v3 0/8] drivers: add new variants of devm_platform_ioremap_resource()

From: Bartosz Golaszewski
Date: Mon Nov 04 2019 - 04:29:37 EST


wt., 22 paÅ 2019 o 10:43 Bartosz Golaszewski <brgl@xxxxxxxx> napisaÅ(a):
>
> From: Bartosz Golaszewski <bgolaszewski@xxxxxxxxxxxx>
>
> Note: resending with Arnd's review tags and rebased on top of char-misc-next
>
> The new devm_platform_ioremap_resource() helper has now been widely
> adopted and used in many drivers. Users of the write-combined ioremap()
> variants could benefit from the same code shrinkage. This series provides
> a write-combined version of devm_platform_ioremap_resource() and uses it in a
> relevant driver with the assumption that - just like was the case
> previously - a coccinelle script will be developed to ease the transition
> for others.
>
> There are also users of platform_get_resource_byname() who call
> devm_ioremap_resource() next, so provide another variant that they can use
> together with two examples.
>
> v1 -> v2:
> - dropped everything related to nocache ioremap as this is going away
>
> v2 -> v3:
> - don't call platform_get_resource() as an argument of devm_ioremap_resource(),
> it actually decreases readability
> - add devm_platform_ioremap_resource_byname() as another variant
>
> Bartosz Golaszewski (8):
> Documentation: devres: add missing entry for
> devm_platform_ioremap_resource()
> lib: devres: prepare devm_ioremap_resource() for more variants
> lib: devres: provide devm_ioremap_resource_wc()
> drivers: platform: provide devm_platform_ioremap_resource_wc()
> misc: sram: use devm_platform_ioremap_resource_wc()
> drivers: provide devm_platform_ioremap_resource_byname()
> gpio: mvebu: use devm_platform_ioremap_resource_byname()
> gpio: tegra186: use devm_platform_ioremap_resource_byname()
>
> .../driver-api/driver-model/devres.rst | 4 ++
> drivers/base/platform.c | 39 +++++++++++-
> drivers/gpio/gpio-mvebu.c | 19 +++---
> drivers/gpio/gpio-tegra186.c | 4 +-
> drivers/misc/sram.c | 28 +++------
> include/linux/device.h | 2 +
> include/linux/platform_device.h | 6 ++
> lib/devres.c | 62 +++++++++++++------
> 8 files changed, 108 insertions(+), 56 deletions(-)
>
> --
> 2.23.0
>

Hi Greg,

can you pick it up for char-misc for v5.5? This was reviewed by Arnd.

Best regards,
Bartosz Golaszewski