Re: [PATCH v2] mm/memory-failure.c: replace with page_shift() in add_to_kill()

From: Yunfeng Ye
Date: Tue Nov 05 2019 - 05:19:13 EST




On 2019/11/5 17:50, David Hildenbrand wrote:
> On 05.11.19 10:38, Yunfeng Ye wrote:
>> The function page_shift() is supported after the commit 94ad9338109f
>> ("mm: introduce page_shift()").
>>
>> So replace with page_shift() in add_to_kill() for readability.
>>
>> Signed-off-by: Yunfeng Ye <yeyunfeng@xxxxxxxxxx>
>> Reviewed-by: David Hildenbrand <david@xxxxxxxxxx>
>> Acked-by: Naoya Horiguchi <n-horiguchi@xxxxxxxxxxxxx>
>> ---
>> v1 -> v2:
>> Â - add Reviewed-by and Acked-by
>
> Note for the future: No need to resend if there were no code/documentation changes. Andrew will apply the tags when picking up the patch.
>
ok, thanks.

>>
>> Â mm/memory-failure.c | 2 +-
>> Â 1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/mm/memory-failure.c b/mm/memory-failure.c
>> index 3151c87dff73..e48c50cac889 100644
>> --- a/mm/memory-failure.c
>> +++ b/mm/memory-failure.c
>> @@ -326,7 +326,7 @@ static void add_to_kill(struct task_struct *tsk, struct page *p,
>> ÂÂÂÂÂ if (is_zone_device_page(p))
>> ÂÂÂÂÂÂÂÂÂ tk->size_shift = dev_pagemap_mapping_shift(p, vma);
>> ÂÂÂÂÂ else
>> -ÂÂÂÂÂÂÂ tk->size_shift = compound_order(compound_head(p)) + PAGE_SHIFT;
>> +ÂÂÂÂÂÂÂ tk->size_shift = page_shift(compound_head(p));
>>
>> ÂÂÂÂÂ /*
>> ÂÂÂÂÂÂ * Send SIGKILL if "tk->addr == -EFAULT". Also, as
>>
>
>