On Fri, Nov 15, 2019 at 11:27:50AM +0800, yu kuai wrote:Thank you for your advise, I'll try to rename it better with comments.
'dentry_d_lock_class' can be used for spin_lock_nested in case lockdep
confused about two different dentry take the 'd_lock'.
However, a single 'DENTRY_D_LOCK_NESTED' may not be enough if more than
two dentry are involed. So, and in 'DENTRY_D_LOCK_NESTED_2'
Signed-off-by: yu kuai <yukuai3@xxxxxxxxxx>
---
include/linux/dcache.h | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/include/linux/dcache.h b/include/linux/dcache.h
index 10090f1..8eb84ef 100644
--- a/include/linux/dcache.h
+++ b/include/linux/dcache.h
@@ -129,7 +129,8 @@ struct dentry {
enum dentry_d_lock_class
{
DENTRY_D_LOCK_NORMAL, /* implicitly used by plain spin_lock() APIs. */
- DENTRY_D_LOCK_NESTED
+ DENTRY_D_LOCK_NESTED,
+ DENTRY_D_LOCK_NESTED_2
You should document this, as "_2" does not make much sense to anyone
only looking at the code :(
Or rename it better.
thanks,
greg k-h
.