Re: [PATCH v1] perf session: fix decompression of PERF_RECORD_COMPRESSED records

From: Jiri Olsa
Date: Mon Nov 18 2019 - 05:47:01 EST


On Fri, Nov 15, 2019 at 08:09:19PM +0300, Alexey Budankov wrote:
>
> On 15.11.2019 18:11, Jiri Olsa wrote:
> > On Fri, Nov 15, 2019 at 12:05:14PM +0300, Alexey Budankov wrote:
> <SNIP>
> >> diff --git a/tools/perf/util/session.c b/tools/perf/util/session.c
> >> index f07b8ecb91bc..3f6f812ec4ed 100644
> >> --- a/tools/perf/util/session.c
> >> +++ b/tools/perf/util/session.c
> >> @@ -1957,9 +1957,31 @@ static int __perf_session__process_pipe_events(struct perf_session *session)
> >> return err;
> >> }
> >>
> >> +static union perf_event *
> >> +prefetch_event(char *buf, u64 head, size_t mmap_size,
> >> + bool needs_swap, union perf_event *ret);
> >
> > why not move prefetch_event definition in here?
> > I don't see any need for the static declaration..
>
> It is just for the sake of more readable patch formatting
> and, yes, could be avoided and replaced by the definition.

I think we're trying to avoid static declarations

>
> >
> >> +
> >> static union perf_event *
> >> fetch_mmaped_event(struct perf_session *session,
> >> u64 head, size_t mmap_size, char *buf)
> >> +{
> >> + return prefetch_event(buf, head, mmap_size,
> >> + session->header.needs_swap,
> >> + ERR_PTR(-EINVAL));
> >> +}
> >> +
> >> +static union perf_event *
> >> +fetch_decomp_event(struct perf_session *session,
> >> + u64 head, size_t mmap_size, char *buf)
> >> +{
> >
> > if this is decomp specific, it could take 'struct decomp*' as argument
>
> Well, it makes sense. whole session object is not required here.
> Just session->header.needs_swap could be passed as a param.
> Shall we make it like this?
>
> static union perf_event *
> fetch_decomp_event(u64 head, size_t mmap_size, char *buf, bool needs_swap)

ok, I just saw the call passing all the stuff from 'struct decomp'
so I thought it'd save some arguments if we pass the struct itself
instead

jirka