Re: [PATCH v5 0/6] KVM: X86: Cleanups on dest_mode and headers

From: Paolo Bonzini
Date: Thu Dec 05 2019 - 07:43:22 EST


I actually prefer 0 to APIC_DEST_NOSHORT, but who am I to complain if
someone else is actually cleaning things up.

Queued, thanks.

Paolo

On 04/12/19 20:07, Peter Xu wrote:
> v5:
> - rename param of ioapic_to_lapic_dest_mode to dest_mode_logical [Sean]
> - in patch 5, also do s/short_hand/shorthand/ for kvm_apic_match_dest [Vitaly]
> - one more r-b picked
>
> v4:
> - address all comments from Vitaly, adding r-bs properly
> - added one more trivial patch:
> "KVM: X86: Conert the last users of "shorthand = 0" to use macros"
>
> v3:
> - address all the comments from both Vitaly and Sean
> - since at it, added patches:
> "KVM: X86: Fix kvm_bitmap_or_dest_vcpus() to use irq shorthand"
> "KVM: X86: Drop KVM_APIC_SHORT_MASK and KVM_APIC_DEST_MASK"
>
> Each patch explains itself.
>
> Please have a look, thanks.
>
> Peter Xu (6):
> KVM: X86: Fix kvm_bitmap_or_dest_vcpus() to use irq shorthand
> KVM: X86: Move irrelevant declarations out of ioapic.h
> KVM: X86: Use APIC_DEST_* macros properly in kvm_lapic_irq.dest_mode
> KVM: X86: Drop KVM_APIC_SHORT_MASK and KVM_APIC_DEST_MASK
> KVM: X86: Fix callers of kvm_apic_match_dest() to use correct macros
> KVM: X86: Conert the last users of "shorthand = 0" to use macros
>
> arch/x86/include/asm/kvm_host.h | 5 +++++
> arch/x86/kvm/hyperv.c | 1 +
> arch/x86/kvm/ioapic.c | 24 +++++++++++++++---------
> arch/x86/kvm/ioapic.h | 6 ------
> arch/x86/kvm/irq.h | 3 +++
> arch/x86/kvm/irq_comm.c | 12 +++++++-----
> arch/x86/kvm/lapic.c | 9 +++------
> arch/x86/kvm/lapic.h | 9 +++++----
> arch/x86/kvm/svm.c | 4 ++--
> arch/x86/kvm/x86.c | 4 ++--
> 10 files changed, 43 insertions(+), 34 deletions(-)
>