Re: [PATCH] staging: wfx: fix reset GPIO polarity

From: JÃrÃme Pouiller
Date: Thu Dec 05 2019 - 09:08:31 EST


On Wednesday 4 December 2019 17:59:46 CET MichaÅ MirosÅaw wrote:
> Driver inverts meaning of GPIO_ACTIVE_LOW/HIGH. Fix it to prevent
> confusion.
>
> Signed-off-by: MichaÅ MirosÅaw <mirq-linux@xxxxxxxxxxxx>
> ---
> drivers/staging/wfx/bus_spi.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/staging/wfx/bus_spi.c b/drivers/staging/wfx/bus_spi.c
> index ab0cda1e124f..73d0157a86ba 100644
> --- a/drivers/staging/wfx/bus_spi.c
> +++ b/drivers/staging/wfx/bus_spi.c
> @@ -199,9 +199,9 @@ static int wfx_spi_probe(struct spi_device *func)
> if (!bus->gpio_reset) {
> dev_warn(&func->dev, "try to load firmware anyway\n");
> } else {
> - gpiod_set_value(bus->gpio_reset, 0);
> - udelay(100);
> gpiod_set_value(bus->gpio_reset, 1);
> + udelay(100);
> + gpiod_set_value(bus->gpio_reset, 0);
> udelay(2000);
> }
Hello MichaÅ,

I did not find real consensus in kernel code. My personal taste would
be to keep this gpio "ACTIVE_HIGH" and rename it gpio_nreset. What do
you think about it?

(in add, this solution would explicitly change the name of the DT
attribute instead of changing the semantic of the existing attribute)

--
JÃrÃme Pouiller