Re: [PATCH v3] fs: introduce is_dot_dotdot helper for cleanup
From: Matthew Wilcox
Date: Sun Dec 08 2019 - 07:38:37 EST
On Sun, Dec 08, 2019 at 03:41:44AM +0000, Al Viro wrote:
> On Sat, Dec 07, 2019 at 07:35:48PM +0800, Tiezhu Yang wrote:
> > There exists many similar and duplicate codes to check "." and "..",
> > so introduce is_dot_dotdot helper to make the code more clean.
> Umm... No objections, in principle, but... you try to say that name
> (e.g. in a phone conversation) without stuttering ;-/
> Any suggestions from native speakers?
I used "is_dot_or_dotdot" when discussing this patch with my wife verbally.