Re: [PATCH] ACPI/HMAT: Fix the parsing of Cache Associativity and Write Policy

From: Rafael J. Wysocki
Date: Tue Dec 10 2019 - 03:06:42 EST


On Tue, Dec 10, 2019 at 2:04 AM Tao Xu <tao3.xu@xxxxxxxxx> wrote:
>
> On 12/9/2019 6:01 PM, Rafael J. Wysocki wrote:
> > On Mon, Dec 2, 2019 at 8:03 AM Tao Xu <tao3.xu@xxxxxxxxx> wrote:
> >>
> >> In chapter 5.2.27.5, Table 5-147: Field "Cache Attributes" of
> >> ACPI 6.3 spec: 0 is "None", 1 is "Direct Mapped", 2 is "Complex Cache
> >> Indexing" for Cache Associativity; 0 is "None", 1 is "Write Back",
> >> 2 is "Write Through" for Write Policy.
> >
> > Well, I'm not sure what the connection between the above statement,
> > which is correct AFAICS, and the changes made by the patch is.
> >
> > Is that the *_OTHER symbol names are confusing or something deeper?
> >
>
> Because in include/acpi/actbl1.h:
>
> #define ACPI_HMAT_CA_NONE (0)
>
> ACPI_HMAT_CA_NONE is 0, but in include/linux/node.h:
>
> enum cache_indexing {
> NODE_CACHE_DIRECT_MAP,
> NODE_CACHE_INDEXED,
> NODE_CACHE_OTHER,
> };
> NODE_CACHE_OTHER is 2, and for otner enum:
>
> case ACPI_HMAT_CA_DIRECT_MAPPED:
> tcache->cache_attrs.indexing = NODE_CACHE_DIRECT_MAP;
> break;
> case ACPI_HMAT_CA_COMPLEX_CACHE_INDEXING:
> tcache->cache_attrs.indexing = NODE_CACHE_INDEXED;
> break;
> in include/acpi/actbl1.h:
>
> #define ACPI_HMAT_CA_DIRECT_MAPPED (1)
> #define ACPI_HMAT_CA_COMPLEX_CACHE_INDEXING (2)
>
> but in include/linux/node.h:
>
> NODE_CACHE_DIRECT_MAP is 0, NODE_CACHE_INDEXED is 1. This is incorrect.

Why is it incorrect?

> And same for enum cache_write_policy.