Re: [PATCH 1/3] pinctrl: pinctrl-intel: Use GPIO direction definitions
From: Andy Shevchenko
Date: Wed Dec 11 2019 - 09:54:55 EST
On Wed, Dec 11, 2019 at 04:32:24PM +0200, Matti Vaittinen wrote:
> Use new GPIO_LINE_DIRECTION_IN and GPIO_LINE_DIRECTION_OUT when
> returning GPIO direction to GPIO framework.
Thanks for the patch!
My comment below.
> - return !!(padcfg0 & PADCFG0_GPIOTXDIS);
> + return padcfg0 & PADCFG0_GPIOTXDIS ? GPIO_LINE_DIRECTION_IN :
> + GPIO_LINE_DIRECTION_OUT;
Despite I have told about ternary operator before, the most important here is
readability as well. With these definitions applied to the initial code the
readability has been slightly decreased.
Two variants to fix, though I prefer second one due to less stack use.
tmp = padcfg0 & PADCFG0_GPIOTXDIS;
return tmp ? GPIO_LINE_DIRECTION_IN : GPIO_LINE_DIRECTION_OUT;
if (padcfg0 & PADCFG0_GPIOTXDIS)
With Best Regards,