Re: [RESEND][PATCH v16 1/5] dma-buf: Add dma-buf heaps framework
From: John Stultz
Date: Thu Dec 12 2019 - 13:33:49 EST
On Thu, Dec 12, 2019 at 8:52 AM Andrew F. Davis <afd@xxxxxx> wrote:
> On 12/3/19 12:26 PM, John Stultz wrote:
> > +#define DMA_HEAP_IOC_MAGIC 'H'
> > +
> > +/**
> > + * DOC: DMA_HEAP_IOC_ALLOC - allocate memory from pool
> > + *
> > + * Takes a dma_heap_allocation_data struct and returns it with the fd field
> > + * populated with the dmabuf handle of the allocation.
> > + */
> > +#define DMA_HEAP_IOC_ALLOC _IOWR(DMA_HEAP_IOC_MAGIC, 0x0,\
> > + struct dma_heap_allocation_data)
> > +
> Seems more common for the internal numberings and such, what the user
> calls is more often (espesially in DRM and DMA_BUF):
> This is really just another naming nit but becouse this one really *is*
> ABI then getting our prefrence right is a must, up to you here.
So yea, Sumit has already pulled these into drm-misc-next, so this
feedback is just a few days too late.
But it's not a bad suggestion, so if you want to submit a tack-on
patch to drm-misc-next I suspect we can, try to pull it in.