Re: [RFC] btf: Some structs are doubled because of struct ring_buffer

From: Steven Rostedt
Date: Fri Dec 13 2019 - 12:11:25 EST

On Fri, 13 Dec 2019 08:51:57 -0800
Alexei Starovoitov <alexei.starovoitov@xxxxxxxxx> wrote:

> It had two choices. Both valid. I don't know why gdb picked this one.
> So yeah I think renaming 'ring_buffer' either in ftrace or in perf would be
> good. I think renaming ftrace one would be better, since gdb picked perf one
> for whatever reason.

Because of the sort algorithm. But from a technical perspective, the
ring buffer that ftrace uses is generic, where the perf ring buffer can
only be used for perf. Call it "event_ring_buffer" or whatever, but
it's not generic and should not have a generic name.

-- Steve