Re: [RFC] btf: Some structs are doubled because of struct ring_buffer
From: Jiri Olsa
Date: Fri Dec 13 2019 - 13:29:07 EST
On Fri, Dec 13, 2019 at 09:30:18AM -0800, Alexei Starovoitov wrote:
> On Fri, Dec 13, 2019 at 12:11:18PM -0500, Steven Rostedt wrote:
> > On Fri, 13 Dec 2019 08:51:57 -0800
> > Alexei Starovoitov <alexei.starovoitov@xxxxxxxxx> wrote:
> > > It had two choices. Both valid. I don't know why gdb picked this one.
> > > So yeah I think renaming 'ring_buffer' either in ftrace or in perf would be
> > > good. I think renaming ftrace one would be better, since gdb picked perf one
> > > for whatever reason.
> > Because of the sort algorithm. But from a technical perspective, the
> > ring buffer that ftrace uses is generic, where the perf ring buffer can
> > only be used for perf. Call it "event_ring_buffer" or whatever, but
> > it's not generic and should not have a generic name.
> I don't mind whichever way. Just saying it would be good to rename :)
any chance we could use the 'struct perf_buffer' for perf?