Re: [PATCH 42/58] tty/serial: Migrate sprd_serial to use has_sysrq

From: Chunyan Zhang
Date: Sun Dec 15 2019 - 21:31:26 EST


On Fri, 13 Dec 2019 at 08:09, Dmitry Safonov <dima@xxxxxxxxxx> wrote:
>
> The SUPPORT_SYSRQ ifdeffery is not nice as:
> - May create misunderstanding about sizeof(struct uart_port) between
> different objects
> - Prevents moving functions from serial_core.h
> - Reduces readability (well, it's ifdeffery - it's hard to follow)
>
> In order to remove SUPPORT_SYSRQ, has_sysrq variable has been added.
> Initialise it in driver's probe and remove ifdeffery.
>
> Cc: Baolin Wang <baolin.wang7@xxxxxxxxx>
> Cc: Chunyan Zhang <zhang.lyra@xxxxxxxxx>
> Cc: Orson Zhai <orsonzhai@xxxxxxxxx>
> Signed-off-by: Dmitry Safonov <dima@xxxxxxxxxx>

Acked-by: Chunyan Zhang <zhang.lyra@xxxxxxxxx>

> ---
> drivers/tty/serial/sprd_serial.c | 5 +----
> 1 file changed, 1 insertion(+), 4 deletions(-)
>
> diff --git a/drivers/tty/serial/sprd_serial.c b/drivers/tty/serial/sprd_serial.c
> index 31df23502562..0c3b7420b01e 100644
> --- a/drivers/tty/serial/sprd_serial.c
> +++ b/drivers/tty/serial/sprd_serial.c
> @@ -3,10 +3,6 @@
> * Copyright (C) 2012-2015 Spreadtrum Communications Inc.
> */
>
> -#if defined(CONFIG_SERIAL_SPRD_CONSOLE) && defined(CONFIG_MAGIC_SYSRQ)
> -#define SUPPORT_SYSRQ
> -#endif
> -
> #include <linux/clk.h>
> #include <linux/console.h>
> #include <linux/delay.h>
> @@ -1227,6 +1223,7 @@ static int sprd_probe(struct platform_device *pdev)
> up->fifosize = SPRD_FIFO_SIZE;
> up->ops = &serial_sprd_ops;
> up->flags = UPF_BOOT_AUTOCONF;
> + up->has_sysrq = IS_ENABLED(CONFIG_SERIAL_SPRD_CONSOLE);
>
> ret = sprd_clk_init(up);
> if (ret)
> --
> 2.24.0
>