Re: [PATCH net] af_packet: refactoring code for prb_calc_retire_blk_tmo

From: Willem de Bruijn
Date: Thu Dec 19 2019 - 08:57:35 EST


On Wed, Dec 18, 2019 at 8:37 PM Mao Wenan <maowenan@xxxxxxxxxx> wrote:
>
> If __ethtool_get_link_ksettings() is failed and with
> non-zero value, prb_calc_retire_blk_tmo() should return
> DEFAULT_PRB_RETIRE_TOV firstly. Refactoring code and make
> it more readable.
>
> Fixes: b43d1f9f7067 ("af_packet: set defaule value for tmo")

This is a pure refactor, not a fix.

Code refactors make backporting fixes across releases harder, among
other things. I think this code is better left as is. Either way, it
would be a candidate for net-next, not net.

> - unsigned int mbits = 0, msec = 0, div = 0, tmo = 0;
> + unsigned int mbits = 0, msec = 1, div = 0, tmo = 0;

Most of these do not need to be initialized here at all, really.