Re: [PATCH] perf tools: Fix variable name's inconsistency in hists__for_each macro

From: 'Arnaldo Carvalho de Melo'
Date: Thu Dec 19 2019 - 11:54:29 EST


Em Thu, Dec 19, 2019 at 09:51:06AM +0100, Jiri Olsa escreveu:
> On Thu, Dec 19, 2019 at 08:08:32AM +0000, fujita.yuya@xxxxxxxxxxx wrote:
> > From: Yuya Fujita <fujita.yuya@xxxxxxxxxxx>
> >
> > Variable names are inconsistent in hists__for_each macro.
> > Due to this inconsistency, the macro replaces its second argument with "fmt"
> > regardless of its original name.
> > So far it works because only "fmt" is passed to the second argument.
>
> hum, I think it works because all the instances that use these macros
> have 'fmt' variable passed in

Exactly, that is what he said :-)

Nice catch!

> > However, this behavior is not expected and should be fixed.
> >
> > Fixes: f0786af536bb ("perf hists: Introduce hists__for_each_format macro")
> > Fixes: aa6f50af822a ("perf hists: Introduce hists__for_each_sort_list macro")
>
> nice ;-)
>
> Acked-by: Jiri Olsa <jolsa@xxxxxxxxxx>

Applied.

> thanks,
> jirka
>
> > Signed-off-by: Yuya Fujita <fujita.yuya@xxxxxxxxxxx>
> > ---
> > tools/perf/util/hist.h | 4 ++--
> > 1 files changed, 2 insertions(+), 2 deletions(-)
> >
> > diff --git a/tools/perf/util/hist.h b/tools/perf/util/hist.h
> > index 4528690..0aa63ae 100644
> > --- a/tools/perf/util/hist.h
> > +++ b/tools/perf/util/hist.h
> > @@ -339,10 +339,10 @@ static inline void perf_hpp__prepend_sort_field(struct perf_hpp_fmt *format)
> > list_for_each_entry_safe(format, tmp, &(_list)->sorts, sort_list)
> >
> > #define hists__for_each_format(hists, format) \
> > - perf_hpp_list__for_each_format((hists)->hpp_list, fmt)
> > + perf_hpp_list__for_each_format((hists)->hpp_list, format)
> >
> > #define hists__for_each_sort_list(hists, format) \
> > - perf_hpp_list__for_each_sort_list((hists)->hpp_list, fmt)
> > + perf_hpp_list__for_each_sort_list((hists)->hpp_list, format)
> >
> > extern struct perf_hpp_fmt perf_hpp__format[];
> >
> > --
> > 1.7.1
> >

--

- Arnaldo