On Tue, Jan 28, 2020 at 02:13:17PM -0800, Sowjanya Komatineni wrote:Will fix prefix in v2
On 1/28/20 1:45 PM, Helen Koike wrote:[...]
[...]On 1/28/20 4:23 PM, Sowjanya Komatineni wrote:
Perhaps this structure should be prefixed with a tegra210_ to make thatCurrently driver supports Tegra210 only. Later we will add for Tegra186 and+const struct tegra_csi_fops csi2_fops = {If I saw correctly, you don't have other instances of struct tegra_csi_fops with different functions.
+ .hw_init = csi2_hw_init,
+ .csi_start_streaming = csi2_start_streaming,
+ .csi_err_status = csi2_error_status,
+};
So why not exposing the functions directly instead of creating a global variable?
Tegra184 support too where we will have separate csi fops.
more obvious?
Will fix in v2Also, why do we need to export these? These will be built as linked into+EXPORT_SYMBOL(csi2_fops);
the Tegra VI driver, which is the only one that uses these, right? Would
it not be enough to just make it global? Why the need to export?
Thierry