On Mon, 2020-02-03 at 11:55 -0700, Shuah Khan wrote:
On 2/3/20 6:21 AM, Mimi Zohar wrote:
On Wed, 2020-01-29 at 19:08 -0800, Joe Perches wrote:
On Wed, 2020-01-29 at 19:01 -0700, Shuah Khan wrote:
Change messages to messages to make it easier to debug. The following
error message isn't informative enough to figure out what failed.
Change messages to include function information.
Signed-off-by: Shuah Khan <skhan@xxxxxxxxxxxxxxxxxxx>
---
.../integrity/platform_certs/load_powerpc.c | 14 ++++++++------
security/integrity/platform_certs/load_uefi.c | 17 ++++++++++-------
2 files changed, 18 insertions(+), 13 deletions(-)
diff --git a/security/integrity/platform_certs/load_powerpc.c b/security/integrity/platform_certs/load_powerpc.c
perhaps instead add #define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
so all the pr_<level> logging is more specific.
This would prefix all pr_<level> output with "integrity: "
Joe! Sorry for the delay in getting back to you.
Agreed. Joe, could you post a patch with a proper patch description
for this?
I have been looking into this a bit more and there is an opportunity
here to add #define pr_fmt(fmt) KBUILD_MODNAME ": " fmt to integrity.h
and get rid of duplicate defines.
That might work but:
$ git grep --name-only 'integrity\.h' security | xargs grep pr_fmt
security/integrity/digsig.c:#define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
security/integrity/digsig_asymmetric.c:#define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
security/integrity/evm/evm_main.c:#define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
security/security.c:#define pr_fmt(fmt) "LSM: " fmt
Here security.c already uses "LSM: "
Does anyone care about the LSM: prefix?