Re: [PATCH 1/4] drm/msm/dpu: Remove unused function arguments

From: Stephen Boyd
Date: Tue Feb 25 2020 - 14:28:04 EST


Quoting Drew Davenport (2020-02-19 09:42:24)
> Several functions arguments in the resource manager are unused, so
> remove them.
>
> Signed-off-by: Drew Davenport <ddavenport@xxxxxxxxxxxx>
> ---

Reviewed-by: Stephen Boyd <swboyd@xxxxxxxxxxxx>

>
> drivers/gpu/drm/msm/disp/dpu1/dpu_rm.c | 37 ++++++++++----------------
> 1 file changed, 14 insertions(+), 23 deletions(-)
>
> diff --git a/drivers/gpu/drm/msm/disp/dpu1/dpu_rm.c b/drivers/gpu/drm/msm/disp/dpu1/dpu_rm.c
> index 23f5b1433b357..dea1dba441fe7 100644
> --- a/drivers/gpu/drm/msm/disp/dpu1/dpu_rm.c
> +++ b/drivers/gpu/drm/msm/disp/dpu1/dpu_rm.c
> @@ -144,8 +144,7 @@ static int _dpu_rm_hw_blk_create(
> const struct dpu_mdss_cfg *cat,
> void __iomem *mmio,
> enum dpu_hw_blk_type type,
> - uint32_t id,
> - const void *hw_catalog_info)
> + uint32_t id)

It would be good to use u32 instead of uint32_t in this code too. The
kernel style is to use the shorter name for that type.