On Sun, 22 Mar 2020 09:29:32 +0800> Lu Baolu<baolu.lu@xxxxxxxxxxxxxxx> wrote:
On 2020/3/21 7:27, Jacob Pan wrote:I also thought about this but the masks are in vendor specific part of
Memory type related flags can be grouped together for one simpleAs name implies, can this move to intel-iommu.h?
check.
---
v9 renamed from EMT to MTS since these are memory type support
flags. ---
Signed-off-by: Jacob Pan<jacob.jun.pan@xxxxxxxxxxxxxxx>
---
include/uapi/linux/iommu.h | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/include/uapi/linux/iommu.h b/include/uapi/linux/iommu.h
index 4ad3496e5c43..d7bcbc5f79b0 100644
--- a/include/uapi/linux/iommu.h
+++ b/include/uapi/linux/iommu.h
@@ -284,7 +284,10 @@ struct iommu_gpasid_bind_data_vtd {
__u32 pat;
__u32 emt;
};
-
+#define IOMMU_SVA_VTD_GPASID_MTS_MASK
(IOMMU_SVA_VTD_GPASID_CD | \
+ IOMMU_SVA_VTD_GPASID_EMTE
| \
+ IOMMU_SVA_VTD_GPASID_PCD
| \
+
IOMMU_SVA_VTD_GPASID_PWT)
the UAPI.