[PATCH 0/2] staging: vt6656: Refactor the vnt_get_phy_field function
From: Oscar Carter
Date: Fri Apr 10 2020 - 07:29:14 EST
This patch series makes a refactor of the vnt_get_phy_field function
through two patches.
The first one refactors the assignment of the "phy->signal" variable
using a constant array with the correct values for every rate.
The second patch removes duplicate code for the assignment of the
"phy->service" variable by putting it outside the if-else statement due
to it's the same for the two branches.
Oscar Carter (2):
staging: vt6656: Refactor the assignment of the phy->signal variable
staging: vt6656: Remove duplicate code for the phy->service assignment
drivers/staging/vt6656/baseband.c | 104 +++++++-----------------------
1 file changed, 22 insertions(+), 82 deletions(-)
--
2.20.1