[PATCH v2 0/2] staging: vt6656: Refactor the vnt_get_phy_field function
From: Oscar Carter
Date: Sat Apr 11 2020 - 08:26:44 EST
This patch series makes a refactor of the vnt_get_phy_field function
through two patches.
The first one refactors the assignment of the "phy->signal" variable
using a constant array with the correct values for every rate.
The second patch removes duplicate code for the assignment of the
"phy->service" variable by putting it outside the if-else statement due
to it's the same for the two branches.
Changelog v1 -> v2:
- Remove one dimension from the constant array for the "phy->signal"
values and use an OR mask instead of the second array dimension as
Malcolm Priestley has suggested.
Oscar Carter (2):
staging: vt6656: Refactor the assignment of the phy->signal variable
staging: vt6656: Remove duplicate code for the phy->service assignment
drivers/staging/vt6656/baseband.c | 108 ++++++++----------------------
1 file changed, 27 insertions(+), 81 deletions(-)
--
2.20.1