Re: [PATCH] kvm_host: unify VM_STAT and VCPU_STAT definitions in a single place

From: Emanuele Giuseppe Esposito
Date: Tue Apr 14 2020 - 11:57:17 EST




On 4/14/20 10:18 AM, Paolo Bonzini wrote:
On 13/04/20 23:34, Philippe Mathieu-Daudà wrote:
+#define VM_STAT(x, ...) offsetof(struct kvm, stat.x), KVM_STAT_VM, ## __VA_ARGS__
+#define VCPU_STAT(x, ...) offsetof(struct kvm_vcpu, stat.x), KVM_STAT_VCPU, ## __VA_ARGS__
I find this macro expanding into multiple fields odd... Maybe a matter
of taste. Sugggestion, have the macro define the full structure, as in
the arm64 arch:

#define VM_STAT(n, x, ...) { n, offsetof(struct kvm, stat.x),
KVM_STAT_VM, ## __VA_ARGS__ }

Ditto for VCPU_STAT().

Hi Philippe and Paolo,

Yes, that's a good idea. Emanuele, can you switch it to this format?

Sure, I just submitted the v2 version.

Thanks,

Emanuele