Re: [PATCH] rcu/performance: Fix kfree_perf_init() build warning on 32-bit kernels

From: Paul E. McKenney
Date: Wed Jun 03 2020 - 14:11:13 EST


On Tue, May 26, 2020 at 09:14:13PM -0400, Joel Fernandes wrote:
> On Tue, May 26, 2020 at 08:27:44PM +0200, Ingo Molnar wrote:
> [...]
> > ./include/linux/kern_levels.h:5:18: warning: format â%luâ expects argument
> > of type âlong unsigned intâ, but argument 2 has type âunsigned intâ
> > [-Wformat=] 5 | #define KERN_SOH "\001" /* ASCII Start Of Header */ |
> > ^~~~~~
> > ./include/linux/kern_levels.h:9:20: note: in expansion of macro âKERN_SOHâ
> > 9 | #define KERN_ALERT KERN_SOH "1" /* action must be taken immediately */
> > | ^~~~~~~~
> > ./include/linux/printk.h:295:9: note: in expansion of macro âKERN_ALERTâ
> > 295 | printk(KERN_ALERT pr_fmt(fmt), ##__VA_ARGS__)
> > | ^~~~~~~~~~
> > kernel/rcu/rcuperf.c:726:2: note: in expansion of macro âpr_alertâ
> > 726 | pr_alert("kfree object size=%lu\n", kfree_mult * sizeof(struct kfree_obj));
> > | ^~~~~~~~
> > kernel/rcu/rcuperf.c:726:32: note: format string is defined here
> > 726 | pr_alert("kfree object size=%lu\n", kfree_mult * sizeof(struct kfree_obj));
> > | ~~^
> > | |
> > | long unsigned int
> > | %u
> >
> >
> > The reason for the warning is that both kfree_mult and sizeof() are
> > 'int' types on 32-bit kernels, while the format string expects a long.
> >
> > Instead of casting the type to long or tweaking the format string, the
> > most straightforward solution is to upgrade kfree_mult to a long.
> > Since this depends on CONFIG_RCU_PERF_TEST
>
> Thanks for fixing it.
>
> > BTW., could we please also rename this code from 'PERF_TEST'/'perf test'
> > to 'PERFORMANCE_TEST'/'performance test'? At first glance I always
> > mistakenly believe that it's somehow related to perf, while it isn't. =B-)
>
> Would it be better to call it 'RCUPERF_TEST' instead of the
> 'RCU_PERFORMANCE_TEST' you are proposing? I feel the word 'PERFORMANCE' is
> too long. Also, 'rcuperf test' instead of the 'rcu performance test' you are
> proposing. I am Ok with doing it however you and Paul want it though, let me
> know.

As long as we are bikeshedding the name... How about refscale.c and
RCU_REF_SCALE_TEST on the one hand and rcuscale.c and RCU_SCALE_TEST on
the other? That keeps the names reasonably short and does not allude
to perf at all.

> Paul, should I send you a renaming patch for the new performance tests as
> well (which I believe should be in the -dev branch).

I am still modifying refperf/refscale/refwhatever, so I will update
that one.

Thanx, Paul