Re: [PATCH][next] s390/dasd: Use struct_size() helper

From: Gustavo A. R. Silva
Date: Wed Jul 08 2020 - 15:34:17 EST


On Wed, Jul 08, 2020 at 11:13:08AM +0200, Stefan Haberland wrote:
> Am 19.06.20 um 18:56 schrieb Gustavo A. R. Silva:
> > Make use of the struct_size() helper instead of an open-coded version
> > in order to avoid any potential type mistakes. Also, remove unnecessary
> > variable _datasize_.
> >
> > This code was detected with the help of Coccinelle and, audited and
> > fixed manually.
> >
> > Signed-off-by: Gustavo A. R. Silva <gustavoars@xxxxxxxxxx>
>
> Thanks for the patch.
> Tested and applied.

Thanks, Stefan.

--
Gustavo