Re: [PATCH] hwspinlock: sirf: Remove the redundant 'of_match_ptr'

From: Barry Song
Date: Fri Jul 10 2020 - 02:08:30 EST


Baolin Wang <baolin.wang7@xxxxxxxxx> ä2020å6æ9æåä äå12:22åéï
>
> Remove the the redundant 'of_match_ptr' macro to fix below warning
> when the CONFIG_OF is not selected.
>
> All warnings:
> drivers/hwspinlock/sirf_hwspinlock.c:87:34: warning: unused variable
> 'sirf_hwpinlock_ids' [-Wunused-const-variable]
>
> Reported-by: kernel test robot <lkp@xxxxxxxxx>
> Signed-off-by: Baolin Wang <baolin.wang7@xxxxxxxxx>
> ---
> drivers/hwspinlock/sirf_hwspinlock.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/hwspinlock/sirf_hwspinlock.c b/drivers/hwspinlock/sirf_hwspinlock.c
> index 823d3c4f621e..a3f77120bad7 100644
> --- a/drivers/hwspinlock/sirf_hwspinlock.c
> +++ b/drivers/hwspinlock/sirf_hwspinlock.c
> @@ -94,7 +94,7 @@ static struct platform_driver sirf_hwspinlock_driver = {
> .probe = sirf_hwspinlock_probe,
> .driver = {
> .name = "atlas7_hwspinlock",
> - .of_match_table = of_match_ptr(sirf_hwpinlock_ids),
> + .of_match_table = sirf_hwpinlock_ids,

is it better to do?

#ifdef CONFIG_OF
static const struct of_device_id sirf_hwpinlock_ids[] = {
{ .compatible = "sirf,hwspinlock", },
{},
};
MODULE_DEVICE_TABLE(of, sirf_hwpinlock_ids);
#endif

> },
> };
>
> --
> 2.17.1

Thanks
barry