Re: [PATCH 3/7] exec: Move initialization of bprm->filename into alloc_bprm

From: Christoph Hellwig
Date: Wed Jul 15 2020 - 02:35:01 EST


On Tue, Jul 14, 2020 at 08:29:36AM -0500, Eric W. Biederman wrote:
>
> -static struct linux_binprm *alloc_bprm(void)
> +static struct linux_binprm *alloc_bprm(int fd, struct filename *filename)
> {
> struct linux_binprm *bprm = kzalloc(sizeof(*bprm), GFP_KERNEL);
> + int retval = -ENOMEM;
> if (!bprm)
> - return ERR_PTR(-ENOMEM);
> + goto out;
> +

Ok, so here we add to it. Two nitpicks:

The abose is missing a blank line after the declarations, which really
makes things more readable. Also no need for the goto there.

Otherwisel ooks good:

Reviewed-by: Christoph Hellwig <hch@xxxxxx>