Re: [PATCH 11/16] iio: chemical: scd30: Simplify with dev_err_probe()

From: Krzysztof Kozlowski
Date: Wed Aug 26 2020 - 11:57:57 EST


On Wed, Aug 26, 2020 at 05:34:34PM +0200, Tomasz Duszynski wrote:
> On Wed, Aug 26, 2020 at 04:51:48PM +0200, Krzysztof Kozlowski wrote:
> > Common pattern of handling deferred probe can be simplified with
> > dev_err_probe(). Less code and also it prints the error value.
> >
> > Signed-off-by: Krzysztof Kozlowski <krzk@xxxxxxxxxx>
> > ---
> > drivers/iio/chemical/scd30_core.c | 10 +++-------
> > 1 file changed, 3 insertions(+), 7 deletions(-)
> >
> > diff --git a/drivers/iio/chemical/scd30_core.c b/drivers/iio/chemical/scd30_core.c
> > index eac76972f83e..92358797796d 100644
> > --- a/drivers/iio/chemical/scd30_core.c
> > +++ b/drivers/iio/chemical/scd30_core.c
> > @@ -705,13 +705,9 @@ int scd30_probe(struct device *dev, int irq, const char *name, void *priv,
> > indio_dev->available_scan_masks = scd30_scan_masks;
> >
> > state->vdd = devm_regulator_get(dev, "vdd");
> > - if (IS_ERR(state->vdd)) {
> > - if (PTR_ERR(state->vdd) == -EPROBE_DEFER)
> > - return -EPROBE_DEFER;
> > -
> > - dev_err(dev, "failed to get regulator\n");
> > - return PTR_ERR(state->vdd);
> > - }
> > + if (IS_ERR(state->vdd))
> > + return dev_err_probe(dev, PTR_ERR(state->vdd),
> > + "failed to get regulator\n");
>
> I'd say that removing like break would slightly improve readability.
> Besides, staying within 100 columns seems socially acceptable now.
> Otherwise,
>
> Acked-by: Tomasz Duszynski <tomasz.duszynski@xxxxxxxxxxx>

Indeed. Although 80 is still mentioned as preferred (in commit bdc48fa11
and in coding style) but here having longer line would be better.

I guess this could be fixed up easily when applying but if resend is
wanted, let me know.

Best regards,
Krzysztof