[PATCH -next] fs: Fix 'mnt' kernel-doc warning in namespace.c

From: Wang Hai
Date: Fri Sep 11 2020 - 08:34:01 EST


Fixes the following W=1 kernel build warning(s):

fs/namespace.c:1358: warning: Excess function parameter 'mnt' description in 'may_umount_tree'

Rename mnt to m.

Reported-by: Hulk Robot <hulkci@xxxxxxxxxx>
Signed-off-by: Wang Hai <wanghai38@xxxxxxxxxx>
---
fs/namespace.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/fs/namespace.c b/fs/namespace.c
index 098f981dce5..9f9a2664dd7 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -1358,7 +1358,7 @@ void mnt_cursor_del(struct mnt_namespace *ns, struct mount *cursor)

/**
* may_umount_tree - check if a mount tree is busy
- * @mnt: root of mount tree
+ * @m: root of mount tree
*
* This is called to check if a tree of mounts has any
* open files, pwds, chroots or sub mounts that are
--
2.17.1