Re: [PATCH 1/5] staging: rtl8723bs: refactor cckrates{only}_included

From: Joe Perches
Date: Sat Sep 12 2020 - 14:44:08 EST


On Sat, 2020-09-12 at 11:22 -0700, Joe Perches wrote:
> On Sat, 2020-09-12 at 10:45 +0200, Michael Straube wrote:
> > Refactor cckrates_included() and cckratesonly_included() to simplify
> > the code and improve readability.
[]
> diff --git a/drivers/staging/rtl8723bs/core/rtw_wlan_util.c b/drivers/staging/rtl8723bs/core/rtw_wlan_util.c
[]
> bool cckratesonly_included(unsigned char *rate, int ratelen)
> {
[]
> if (i <= 0)
if (ratelen <= 0) of course...

> return false;
>
> for (i = 0; i < ratelen; i++) {
> if (!is_cckrate(rate[i])
> return false;
> }
>
> return true;
> }
>
>