Re: 回复: RCU: Question on force_qs_rnp

From: Paul E. McKenney
Date: Mon Sep 14 2020 - 23:41:44 EST


On Tue, Sep 15, 2020 at 03:18:23AM +0000, Zhang, Qiang wrote:
>
>
> ________________________________________
> 发件人: Paul E. McKenney <paulmck@xxxxxxxxxx>
> 发送时间: 2020年9月15日 4:56
> 收件人: Joel Fernandes
> 抄送: Zhang, Qiang; Uladzislau Rezki; josh@xxxxxxxxxxxxxxxx; rostedt@xxxxxxxxxxx; mathieu.desnoyers@xxxxxxxxxxxx; Lai Jiangshan; rcu@xxxxxxxxxxxxxxx; LKML
> 主题: Re: RCU: Question on force_qs_rnp
>
> On Mon, Sep 14, 2020 at 03:42:08PM -0400, Joel Fernandes wrote:
> > On Mon, Sep 14, 2020 at 07:55:18AM +0000, Zhang, Qiang wrote:
> > > Hello Paul
> > >
> > > I have some questions for you .
> > > in force_qs_rnp func , if "f(rdp)" func return true we will call rcu_report_qs_rnp func
> > > report a quiescent state for this rnp node, and clear grpmask form rnp->qsmask.
> > > after that , can we make a check for this rnp->qsmask, if rnp->qsmask == 0,
> > > we will check blocked readers in this rnp node, instead of jumping directly to the next node .
> >
> > Could you clarify what good is this going to do? What problem are you trying to
> > address?
> >
> > You could have a task that is blocked in an RCU leaf node, but the
> > force_qs_rnp() decided to call rcu_report_qs_rnp(). This is perfectly Ok. The
> > CPU could be dyntick-idle and a quiescent state is reported. However, the GP
> > must not end and the rcu leaf node should still be present in its parent
> > intermediate nodes ->qsmask. In this case, the ->qsmask == 0 does not have
> > any relevance.
> >
> > Or am I missing the point of the question?
>
> >Hello, Qiang,
>
> >Another way of making Joel's point is to say that the additional check
> >you are asking for is already being done, but by rcu_report_qs_rnp().
>
> > Thanx, Paul
>
> Hello Pual, Joel
>
> What I want to express is as follows :
>
> diff --git a/kernel/rcu/tree.c b/kernel/rcu/tree.c
> index 7623128d0020..beb554539f01 100644
> --- a/kernel/rcu/tree.c
> +++ b/kernel/rcu/tree.c
> @@ -2622,6 +2622,11 @@ static void force_qs_rnp(int (*f)(struct rcu_data *rdp))
> if (mask != 0) {
> /* Idle/offline CPUs, report (releases rnp->lock). */
> rcu_report_qs_rnp(mask, rnp, rnp->gp_seq, flags);
> + raw_spin_lock_irqsave_rcu_node(rnp, flags);
> + if (rnp->qsmask == 0 && rcu_preempt_blocked_readers_cgp(rnp))
> + rcu_initiate_boost(rnp, flags);
> + else
> + raw_spin_unlock_irqrestore_rcu_node(rnp, flags);
> } else {
> /* Nothing to do here, so just drop the lock. */
> raw_spin_unlock_irqrestore_rcu_node(rnp, flags);

But in that case, why duplicate the code from rcu_initiate_boost()?

Thanx, Paul